Description:
Finds points at which to cut a pair of curves so that a fillet of given radius can be inserted.
Parameters:
- curve0
- Type: Curve
- First curve to fillet.
- curve1
- Type: Curve
- Second curve to fillet.
- radius
- Type: double
- Fillet radius.
- t0Base
- Type: double
- Parameter value for base point on curve0.
- t1Base
- Type: double
- Parameter value for base point on curve1.
- t0
- Type: double
- Parameter value of fillet point on curve 0.
- t1
- Type: double
- Parameter value of fillet point on curve 1.
- filletPlane
- Type: Plane
- The fillet is contained in this plane with the fillet center at the plane origin.
Returns:
Type: bool
True on success, False on failure.
Remarks:
A fillet point is a pair of curve parameters (t0,t1) such that there is a circle of radius point3 tangent to curve c0 at t0 and tangent to curve c1 at t1. Of all possible fillet points this function returns the one which is the closest to the base point t0Base, t1Base. Distance from the base point is measured by the sum of arc lengths along the two curves.
Available since:
5.0