Description:

Try to convert this curve into an Arc using a custom tolerance.

Syntax:
public bool TryGetArc(
out Arc arc,
double tolerance
)
Parameters:
  • arc
  • Type: Arc
  • On success, the Arc will be filled in.
  • tolerance
  • Type: double
  • Tolerance to use when checking.
Returns:
Type: bool
True if the curve could be converted into an arc.
Available since:
5.0

Description:

Try to convert this curve into an Arc using RhinoMath.ZeroTolerance.

Syntax:
public bool TryGetArc(
out Arc arc
)
Parameters:
  • arc
  • Type: Arc
  • On success, the Arc will be filled in.
Returns:
Type: bool
True if the curve could be converted into an arc.
Available since:
5.0

Description:

Try to convert this curve into an Arc using a custom tolerance.

Syntax:
public bool TryGetArc(
Plane plane,
out Arc arc,
double tolerance
)
Parameters:
  • plane
  • Type: Plane
  • Plane in which the comparison is performed.
  • arc
  • Type: Arc
  • On success, the Arc will be filled in.
  • tolerance
  • Type: double
  • Tolerance to use when checking.
Returns:
Type: bool
True if the curve could be converted into an arc within the given plane.
Available since:
5.0

Description:

Try to convert this curve into an Arc using RhinoMath.ZeroTolerance.

Syntax:
public bool TryGetArc(
Plane plane,
out Arc arc
)
Parameters:
  • plane
  • Type: Plane
  • Plane in which the comparison is performed.
  • arc
  • Type: Arc
  • On success, the Arc will be filled in.
Returns:
Type: bool
True if the curve could be converted into an arc within the given plane.
Available since:
5.0

TryGetArc method

Class:  Rhino.Geometry.Curve

Nothing found