Description:

Extends a curve until it intersects a collection of objects.

Syntax:
public Curve Extend(
CurveEnd side,
CurveExtensionStyle style,
IEnumerable<GeometryBase> geometry
)
Parameters:
  • side
  • Type: CurveEnd
  • The end of the curve to extend.
  • geometry
  • Type: System.Collections.Generic.IEnumerable<GeometryBase>
  • A collection of objects. Allowable object types are Curve, Surface, Brep.
Returns:
Type: Curve
New extended curve result on success, None on failure.
Available since:
5.0

Description:

Extends a curve to a point.

Syntax:
public Curve Extend(
CurveEnd side,
CurveExtensionStyle style,
Point3d endPoint
)
Parameters:
  • side
  • Type: CurveEnd
  • The end of the curve to extend.
  • endPoint
  • Type: Point3d
  • A new end point.
Returns:
Type: Curve
New extended curve result on success, None on failure.
Available since:
5.0

Description:

Extends a curve by a specific length.

Syntax:
public Curve Extend(
CurveEnd side,
double length,
CurveExtensionStyle style
)
Parameters:
  • length
  • Type: double
  • Length to add to the curve end.
Returns:
Type: Curve
A curve with extended ends or None on failure.
Available since:
5.0

Description:

Where possible, analytically extends curve to include the given domain. This will not work on closed curves. The original curve will be identical to the restriction of the resulting curve to the original curve domain.

Syntax:
public Curve Extend(
double t0,
double t1
)
Parameters:
  • t0
  • Type: double
  • Start of extension domain, if the start is not inside the Domain of this curve, an attempt will be made to extend the curve.
  • t1
  • Type: double
  • End of extension domain, if the end is not inside the Domain of this curve, an attempt will be made to extend the curve.
Returns:
Type: Curve
Extended curve on success, None on failure.
Available since:
5.0

Description:

Where possible, analytically extends curve to include the given domain. This will not work on closed curves. The original curve will be identical to the restriction of the resulting curve to the original curve domain.

Syntax:
public Curve Extend(
Interval domain
)
Parameters:
Returns:
Type: Curve
Extended curve on success, None on failure.
Available since:
5.0

Nothing found