Description:

Divide the curve into specific length segments.

Syntax:
public double DivideByLength(
double segmentLength,
bool includeEnds,
bool reverse,
out Point3d[] points
)
Parameters:
  • segmentLength
  • Type: double
  • The length of each and every segment (except potentially the last one).
  • includeEnds
  • Type: bool
  • If true, then the point at the start of the first division segment is returned.
  • reverse
  • Type: bool
  • If true, then the divisions start from the end of the curve.
  • points
  • Type: Point3d[]
  • If function is successful, points at each parameter value are returned in points.
Returns:
Type: double
Array containing division curve parameters if successful, None on failure.
Available since:
6.0

Description:

Divide the curve into specific length segments.

Syntax:
public double DivideByLength(
double segmentLength,
bool includeEnds,
bool reverse
)
Parameters:
  • segmentLength
  • Type: double
  • The length of each and every segment (except potentially the last one).
  • includeEnds
  • Type: bool
  • If true, then the point at the start of the first division segment is returned.
  • reverse
  • Type: bool
  • If true, then the divisions start from the end of the curve.
Returns:
Type: double
Array containing division curve parameters if successful, None on failure.
Available since:
6.0

Description:

Divide the curve into specific length segments.

Syntax:
public double DivideByLength(
double segmentLength,
bool includeEnds,
out Point3d[] points
)
Parameters:
  • segmentLength
  • Type: double
  • The length of each and every segment (except potentially the last one).
  • includeEnds
  • Type: bool
  • If true, then the point at the start of the first division segment is returned.
  • points
  • Type: Point3d[]
  • If function is successful, points at each parameter value are returned in points.
Returns:
Type: double
Array containing division curve parameters if successful, None on failure.
Available since:
5.0

Description:

Divide the curve into specific length segments.

Syntax:
public double DivideByLength(
double segmentLength,
bool includeEnds
)
Parameters:
  • segmentLength
  • Type: double
  • The length of each and every segment (except potentially the last one).
  • includeEnds
  • Type: bool
  • If true, then the point at the start of the first division segment is returned.
Returns:
Type: double
Array containing division curve parameters if successful, None on failure.
Available since:
5.0

Nothing found