Description:

Calculates 3d points on a curve where the linear distance between the points is equal.

Syntax:
public Point3d[] DivideEquidistant(
double distance,
out double curveParameters
)
Parameters:
  • distance
  • Type: double
  • The distance between division points.
  • curveParameters
  • Type: double
  • If successful, an array of curve parameters at the point locations.
Returns:
Type: Point3d[]
An array of equidistant points, or None on error.
Remarks:
Unlike the other divide methods, which divides a curve based on arc length, or the distance along the curve between two points, this function divides a curve based on the linear distance between points.
Available since:
8.14

Description:

Calculates 3d points on a curve where the linear distance between the points is equal.

Syntax:
public Point3d[] DivideEquidistant(
double distance
)
Parameters:
  • distance
  • Type: double
  • The distance between division points.
Returns:
Type: Point3d[]
An array of equidistant points, or None on error.
Remarks:
Unlike the other divide methods, which divides a curve based on arc length, or the distance along the curve between two points, this function divides a curve based on the linear distance between points.
Available since:
5.0

/
/
/
DivideEquidistant

DivideEquidistant method

Class:  Rhino.Geometry.Curve

Nothing found