Description:

Decide if it makes sense to close off this curve by moving the endpoint to the start based on start-end gap size and length of curve as approximated by chord defined by 6 points.

Syntax:
public bool IsClosable(
double tolerance,
double minimumAbsoluteSize,
double minimumRelativeSize
)
Parameters:
  • tolerance
  • Type: double
  • Maximum allowable distance between start and end. If start - end gap is greater than tolerance, this function will return false.
  • minimumAbsoluteSize
  • Type: double
  • If greater than 0.0 and none of the interior sampled points are at least minimumAbsoluteSize from start, this function will return false.
  • minimumRelativeSize
  • Type: double
  • If greater than 1.0 and chord length is less than minimumRelativeSize*gap, this function will return false.
Returns:
Type: bool
True if start and end points are close enough based on above conditions.
Available since:
5.0

Description:

Decide if it makes sense to close off this curve by moving the endpoint to the start based on start-end gap size and length of curve as approximated by chord defined by 6 points.

Syntax:
public bool IsClosable(
double tolerance
)
Parameters:
  • tolerance
  • Type: double
  • Maximum allowable distance between start and end. If start - end gap is greater than tolerance, this function will return false.
Returns:
Type: bool
True if start and end points are close enough based on above conditions.
Available since:
5.0

IsClosable method

Class:  Rhino.Geometry.Curve

Nothing found