Offset a curve on a brep face surface. This curve must lie on the surface. This overload allows to specify different offsets for different curve parameters.
- face
- Type: BrepFace
- The brep face on which to offset.
- curveParameters
- Type: double
- Curve parameters corresponding to the offset distances.
- offsetDistances
- Type: double
- distances to offset (+)left, (-)right.
- fittingTolerance
- Type: double
- A fitting tolerance.
Offset this curve on a brep face surface. This curve must lie on the surface.
Offset a curve on a brep face surface. This curve must lie on the surface. This overload allows to specify a surface point at which the offset will pass.
Offset this curve on a surface. This curve must lie on the surface. This overload allows to specify different offsets for different curve parameters.
- surface
- Type: Surface
- A surface on which to offset.
- curveParameters
- Type: double
- Curve parameters corresponding to the offset distances.
- offsetDistances
- Type: double
- Distances to offset (+)left, (-)right.
- fittingTolerance
- Type: double
- A fitting tolerance.
Offset a curve on a surface. This curve must lie on the surface.
Offset a curve on a surface. This curve must lie on the surface. This overload allows to specify a surface point at which the offset will pass.