Description:
Makes a curve blend between 2 curves at the parameters specified with the directions and continuities specified
Syntax:
public static Curve CreateBlendCurve(
Curve curve0,
double t0,
bool reverse0,
BlendContinuity continuity0,
Curve curve1,
double t1,
bool reverse1,
BlendContinuity continuity1
)
Curve curve0,
double t0,
bool reverse0,
BlendContinuity continuity0,
Curve curve1,
double t1,
bool reverse1,
BlendContinuity continuity1
)
Parameters:
- curve0
- Type: Curve
- First curve to blend from
- t0
- Type: double
- Parameter on first curve for blend endpoint
- reverse0
- Type: bool
- If false, the blend will go in the natural direction of the curve. If true, the blend will go in the opposite direction to the curve
- continuity0
- Type: BlendContinuity
- Continuity for the blend at the start
- curve1
- Type: Curve
- Second curve to blend from
- t1
- Type: double
- Parameter on second curve for blend endpoint
- reverse1
- Type: bool
- If false, the blend will go in the natural direction of the curve. If true, the blend will go in the opposite direction to the curve
- continuity1
- Type: BlendContinuity
- Continuity for the blend at the end
Returns:
Type: Curve
The blend curve on success. None on failure
Available since:
5.0
Description:
Create a Blend curve between two existing curves.
Parameters:
- curveA
- Type: Curve
- Curve to blend from (blending will occur at curve end point).
- curveB
- Type: Curve
- Curve to blend to (blending will occur at curve start point).
- continuity
- Type: BlendContinuity
- Continuity of blend.
- bulgeA
- Type: double
- Bulge factor at curveA end of blend. Values near 1.0 work best.
- bulgeB
- Type: double
- Bulge factor at curveB end of blend. Values near 1.0 work best.
Returns:
Type: Curve
A curve representing the blend between A and B or None on failure.
Available since:
5.0
Description:
Create a Blend curve between two existing curves.
Syntax:
Parameters:
- curveA
- Type: Curve
- Curve to blend from (blending will occur at curve end point).
- curveB
- Type: Curve
- Curve to blend to (blending will occur at curve start point).
- continuity
- Type: BlendContinuity
- Continuity of blend.
Returns:
Type: Curve
A curve representing the blend between A and B or None on failure.
Available since:
5.0