Description:

Interpolates a sequence of points. Used by InterpCurve Command This routine works best when degree=3.

Syntax:
public static Curve CreateInterpolatedCurve(
IEnumerable<Point3d> points,
int degree,
CurveKnotStyle knots,
Vector3d startTangent,
Vector3d endTangent
)
Parameters:
  • points
  • Type: IEnumerable<Point3d>
  • Points to interpolate. For periodic curves if the final point is a duplicate of the initial point it is ignored. (Count must be >=2)
  • degree
  • Type: int
  • The degree of the curve >=1. Note: Even degree > 3 periodic interpolation results in a non-periodic closed curve.
  • knots
  • Type: CurveKnotStyle
  • Knot-style to use and specifies if the curve should be periodic.
  • startTangent
  • Type: Vector3d
  • A starting tangent.
  • endTangent
  • Type: Vector3d
  • An ending tangent.
Returns:
Type: Curve
interpolated curve on success. None on failure.
Available since:
5.0

Description:

Interpolates a sequence of points. Used by InterpCurve Command This routine works best when degree=3.

Syntax:
public static Curve CreateInterpolatedCurve(
IEnumerable<Point3d> points,
int degree,
CurveKnotStyle knots
)
Parameters:
  • points
  • Type: IEnumerable<Point3d>
  • Points to interpolate. For periodic curves if the final point is a duplicate of the initial point it is ignored. (Count must be >=2)
  • degree
  • Type: int
  • The degree of the curve >=1. Note: Even degree > 3 periodic interpolation results in a non-periodic closed curve.
  • knots
  • Type: CurveKnotStyle
  • Knot-style to use and specifies if the curve should be periodic.
Returns:
Type: Curve
interpolated curve on success. None on failure.
Available since:
5.0

Description:

Interpolates a sequence of points. Used by InterpCurve Command This routine works best when degree=3.

Syntax:
public static Curve CreateInterpolatedCurve(
IEnumerable<Point3d> points,
int degree
)
Parameters:
  • points
  • Type: IEnumerable<Point3d>
  • Points to interpolate (Count must be >= 2)
  • degree
  • Type: int
  • The degree of the curve >=1. Degree must be odd.
Returns:
Type: Curve
interpolated curve on success. None on failure.
Available since:
5.0

/
/
/
CreateInterpolatedCurve

CreateInterpolatedCurve method

Class:  Rhino.Geometry.Curve

Nothing found