Description:

Creates a soft edited curve from an existing curve using a smooth field of influence.

Syntax:
public static Curve CreateSoftEditCurve(
Curve curve,
double t,
Vector3d delta,
double length,
bool fixEnds
)
Parameters:
  • curve
  • Type: Curve
  • The curve to soft edit.
  • t
  • Type: double
  • A parameter on the curve to move from. This location on the curve is moved, and the move is smoothly tapered off with increasing distance along the curve from this parameter.
  • delta
  • Type: Vector3d
  • The direction and magnitude, or maximum distance, of the move.
  • length
  • Type: double
  • The distance along the curve from the editing point over which the strength of the editing falls off smoothly.
Returns:
Type: Curve
The soft edited curve if successful. None on failure.
Available since:
6.0

/
/
/
CreateSoftEditCurve

CreateSoftEditCurve method

Class:  Rhino.Geometry.Curve

Nothing found