Description:

Creates a constant-radius fillet surface between a surface and the curve.

Syntax:
public bool FilletSurfaceToCurve(
BrepFace face,
double t,
double u,
double v,
double radius,
int alignToCurve,
int railDegree,
int arcDegree,
IEnumerable<double> arcSliders,
int numBezierSrfs,
double tolerance,
List<Brep> out_fillets,
out double fitResults
)
Parameters:
  • face
  • Type: BrepFace
  • the face being filleted.
  • t
  • Type: double
  • A parameter on the curve, indicating region of fillet.
  • u
  • Type: double
  • A parameter in the u direction of the face indicating which side of the curve to fillet.
  • v
  • Type: double
  • A parameter in the v direction of the face indicating which side of the curve to fillet.
  • radius
  • Type: double
  • The radius of the constant-radius fillet desired. NOTE: using arcSliders will change the shape of the arcs themselves
  • alignToCurve
  • Type: int
  • Does the user want the fillet to align to the curve? 0 - No, ignore the curve's b-spline structure 1 - Yes, match the curves's degree, spans, CVs as much as possible 2 - Same as 1, but iterate to fit to tolerance Note that a value of 1 or 2 will cause nBezierSrfs to be ignored
  • railDegree
  • Type: int
  • Desired fillet degree (3 or 5) in the u-direction, along the curve
  • arcDegree
  • Type: int
  • Desired fillet degree (2, 3, 4, or 5) in the v-direction, along the fillet arcs.If 2, then the surface is rational in v
  • arcSliders
  • Type: IEnumerable<double>
  • Array of 2 sliders to shape the fillet in the arc direction, used for arcDegree = 3, 4, or 5; input { 0.0, 0.0 } to ignore [0] (-1 to 1) slides tangent arms from base (-1) to theoretical(1) [1] (-1 to 1) slides inner CV(s) from base (-1) to theoretical(1)
  • numBezierSrfs
  • Type: int
  • If >0, this indicates the number of equally-spaced fillet surfaces to be output in the rail direction, each surface Bézier in u.
  • tolerance
  • Type: double
  • The tolerance. In in doubt, the the document's absolute tolerance.
  • out_fillets
  • Type: List<Brep>
  • he results of the fillet calculation.
  • fitResults
  • Type: double
  • array of doubles indicating fitting results: [0] max 3d point deviation along curve [1] max 3d point deviation along face [2] max angle deviation along face(in degrees) [3] max angle deviation between Bézier surfaces(in degrees) [4] max curvature difference between Bézier surfaces
Returns:
Type: bool
True if successful, False otherwise.
Available since:
8.0

/
/
/
FilletSurfaceToCurve

FilletSurfaceToCurve method

Class:  Rhino.Geometry.Curve

Nothing found