Description:

Gets the parameter along the curve which coincides with a given length along the curve.

Syntax:
public bool LengthParameter(
double segmentLength,
out double t,
double fractionalTolerance,
Interval subdomain
)
Parameters:
  • segmentLength
  • Type: double
  • Length of segment to measure. Must be less than or equal to the length of the sub-domain.
  • t
  • Type: double
  • Parameter such that the length of the curve from the start of the sub-domain to t is s.
  • fractionalTolerance
  • Type: double
  • Desired fractional precision. fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.
  • subdomain
  • Type: Interval
  • The calculation is performed on the specified sub-domain of the curve rather than the whole curve.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Gets the parameter along the curve which coincides with a given length along the curve.

Syntax:
public bool LengthParameter(
double segmentLength,
out double t,
double fractionalTolerance
)
Parameters:
  • segmentLength
  • Type: double
  • Length of segment to measure. Must be less than or equal to the length of the curve.
  • t
  • Type: double
  • Parameter such that the length of the curve from the curve start point to t equals s.
  • fractionalTolerance
  • Type: double
  • Desired fractional precision. fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Gets the parameter along the curve which coincides with a given length along the curve. A fractional tolerance of 1e-8 is used in this version of the function.

Syntax:
public bool LengthParameter(
double segmentLength,
out double t,
Interval subdomain
)
Parameters:
  • segmentLength
  • Type: double
  • Length of segment to measure. Must be less than or equal to the length of the sub-domain.
  • t
  • Type: double
  • Parameter such that the length of the curve from the start of the sub-domain to t is s.
  • subdomain
  • Type: Interval
  • The calculation is performed on the specified sub-domain of the curve rather than the whole curve.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Gets the parameter along the curve which coincides with a given length along the curve. A fractional tolerance of 1e-8 is used in this version of the function.

Syntax:
public bool LengthParameter(
double segmentLength,
out double t
)
Parameters:
  • segmentLength
  • Type: double
  • Length of segment to measure. Must be less than or equal to the length of the curve.
  • t
  • Type: double
  • Parameter such that the length of the curve from the curve start point to t equals length.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

/
/
/
LengthParameter

LengthParameter method

Class:  Rhino.Geometry.Curve

Nothing found