Description:

Removes kinks from a curve. Periodic curves deform smoothly without kinks.

Syntax:
public static Curve CreatePeriodicCurve(
Curve curve,
bool smooth
)
Parameters:
  • curve
  • Type: Curve
  • The curve to make periodic. Curve must have degree >= 2.
  • smooth
  • Type: bool
  • If true, smooths any kinks in the curve and moves control points to make a smooth curve. If false, control point locations are not changed or changed minimally (only one point may move) and only the knot vector is altered.
Returns:
Type: Curve
The resulting curve if successful, None otherwise.
Available since:
6.0

Description:

Removes kinks from a curve. Periodic curves deform smoothly without kinks.

Syntax:
public static Curve CreatePeriodicCurve(
Curve curve
)
Parameters:
  • curve
  • Type: Curve
  • The curve to make periodic. Curve must have degree >= 2.
Returns:
Type: Curve
The resulting curve if successful, None otherwise.
Available since:
6.0

/
/
/
CreatePeriodicCurve

CreatePeriodicCurve method

Class:  Rhino.Geometry.Curve

Nothing found