Description:
Fairs a curve object. Fair works best on degree 3 (cubic) curves. Attempts to remove large curvature variations while limiting the geometry changes to be no more than the specified tolerance.
Parameters:
- distanceTolerance
- Type: double
- Maximum allowed distance the faired curve is allowed to deviate from the input.
- angleTolerance
- Type: double
- (in radians) kinks with angles <= angleTolerance are smoothed out 0.05 is a good default.
- clampStart
- Type: int
- The number of (control vertices-1) to preserve at start. 0 = preserve start point 1 = preserve start point and 1st derivative 2 = preserve start point, 1st and 2nd derivative
- clampEnd
- Type: int
- Same as clampStart.
- iterations
- Type: int
- The number of iterations to use in adjusting the curve.
Returns:
Type: Curve
Returns new faired Curve on success, None on failure.
Available since:
5.0