Description:

Gets a point at a certain length along the curve. The length must be non-negative and less than or equal to the length of the curve. Lengths will not be wrapped when the curve is closed or periodic.

Syntax:
public Point3d PointAtLength(
double length
)
Parameters:
  • length
  • Type: double
  • Length along the curve between the start point and the returned point.
Returns:
Type: Point3d
Point on the curve at the specified length from the start point or Poin3d.Unset on failure.
Available since:
5.0

/
/
/
PointAtLength

PointAtLength method

Class:  Rhino.Geometry.Curve

Nothing found