Description:

Projects a curve to a set of meshes using a direction and tolerance.

Syntax:
public static Curve[] ProjectToMesh(
Curve curve,
IEnumerable<Mesh> meshes,
Vector3d direction,
double tolerance
)
Parameters:
  • meshes
  • Type: IEnumerable<Mesh>
  • A list, an array, or any enumerable of meshes.
  • direction
  • Type: Vector3d
  • A direction vector.
  • tolerance
  • Type: double
  • A tolerance value.
Returns:
Type: Curve[]
An array of curves if successful, an empty array otherwise.
Available since:
5.0

Description:

Projects a curve to a mesh using a direction and tolerance.

Syntax:
public static Curve[] ProjectToMesh(
Curve curve,
Mesh mesh,
Vector3d direction,
double tolerance
)
Parameters:
  • mesh
  • Type: Mesh
  • A mesh.
  • direction
  • Type: Vector3d
  • A direction vector.
  • tolerance
  • Type: double
  • A tolerance value.
Returns:
Type: Curve[]
An array of curves if successful, an empty array otherwise.
Available since:
5.0

Description:

Projects a curve to a set of meshes using a direction and tolerance.

Syntax:
public static Curve[] ProjectToMesh(
IEnumerable<Curve> curves,
IEnumerable<Mesh> meshes,
Vector3d direction,
double tolerance,
bool loose
)
Parameters:
  • curves
  • Type: IEnumerable<Curve>
  • A list, an array, or any enumerable of curves.
  • meshes
  • Type: IEnumerable<Mesh>
  • A list, an array, or any enumerable of meshes.
  • direction
  • Type: Vector3d
  • A direction vector.
  • tolerance
  • Type: double
  • A tolerance value.
  • loose
  • Type: bool
  • If true, then project curve edit points onto meshes.
Returns:
Type: Curve[]
An array of curves if successful, an empty array otherwise.
Available since:
8.17

Description:

Projects a curve to a set of meshes using a direction and tolerance.

Syntax:
public static Curve[] ProjectToMesh(
IEnumerable<Curve> curves,
IEnumerable<Mesh> meshes,
Vector3d direction,
double tolerance
)
Parameters:
  • curves
  • Type: IEnumerable<Curve>
  • A list, an array, or any enumerable of curves.
  • meshes
  • Type: IEnumerable<Mesh>
  • A list, an array, or any enumerable of meshes.
  • direction
  • Type: Vector3d
  • A direction vector.
  • tolerance
  • Type: double
  • A tolerance value.
Returns:
Type: Curve[]
An array of curves if successful, an empty array otherwise.
Available since:
5.0

/
/
/
ProjectToMesh

ProjectToMesh method

Class:  Rhino.Geometry.Curve

Nothing found