Description:
Offsets this curve. If you have a nice offset, then there will be one entry in the array. If the original curve had kinks or the offset curve had self intersections, you will get multiple segments in the output array.
Syntax:
public Curve[] Offset(
Plane plane,
double distance,
double tolerance,
CurveOffsetCornerStyle cornerStyle
)
Plane plane,
double distance,
double tolerance,
CurveOffsetCornerStyle cornerStyle
)
Parameters:
- plane
- Type: Plane
- Offset solution plane.
- distance
- Type: double
- The positive or negative distance to offset.
- tolerance
- Type: double
- The offset or fitting tolerance.
- cornerStyle
- Type: CurveOffsetCornerStyle
- Corner style for offset kinks.
Returns:
Type: Curve[]
Offset curves on success, None on failure.
Available since:
5.0
Description:
Offsets this curve. If you have a nice offset, then there will be one entry in the array. If the original curve had kinks or the offset curve had self intersections, you will get multiple segments in the output array.
Parameters:
- directionPoint
- Type: Point3d
- A point that indicates the direction of the offset.
- normal
- Type: Vector3d
- The normal to the offset plane.
- distance
- Type: double
- The positive or negative distance to offset.
- tolerance
- Type: double
- The offset or fitting tolerance.
- cornerStyle
- Type: CurveOffsetCornerStyle
- Corner style for offset kinks.
Returns:
Type: Curve[]
Offset curves on success, None on failure.
Available since:
5.0
Description:
Offsets this curve. If you have a nice offset, then there will be one entry in the array. If the original curve had kinks or the offset curve had self intersections, you will get multiple segments in the output array.
Syntax:
public Curve[] Offset(
Point3d directionPoint,
Vector3d normal,
double distance,
double tolerance,
double angleTolerance,
bool loose,
CurveOffsetCornerStyle cornerStyle,
CurveOffsetEndStyle endStyle
)
Point3d directionPoint,
Vector3d normal,
double distance,
double tolerance,
double angleTolerance,
bool loose,
CurveOffsetCornerStyle cornerStyle,
CurveOffsetEndStyle endStyle
)
Parameters:
- directionPoint
- Type: Point3d
- A point that indicates the direction of the offset.
- normal
- Type: Vector3d
- The normal to the offset plane.
- distance
- Type: double
- The positive or negative distance to offset.
- tolerance
- Type: double
- The offset or fitting tolerance.
- angleTolerance
- Type: double
- The angle tolerance, in radians, used to decide whether to split at kinks.
- loose
- Type: bool
- If false, offset within tolerance. If true, offset by moving edit points.
- cornerStyle
- Type: CurveOffsetCornerStyle
- Corner style for offset kinks.
- endStyle
- Type: CurveOffsetEndStyle
- End style for non-loose, non-closed curve offsets.
Returns:
Type: Curve[]
Offset curves on success, None on failure.
Available since:
7.0