Description:

Pulls this curve to a brep face and returns the result of that operation.

Syntax:
public Curve[] PullToBrepFace(
BrepFace face,
double tolerance
)
Parameters:
  • tolerance
  • Type: double
  • A tolerance value.
Returns:
Type: Curve[]
An array containing the resulting curves after pulling. This array could be empty.
Available since:
5.0

Description:

Pull a curve to a BrepFace using closest point projection.

Syntax:
public static Curve[] PullToBrepFace(
Curve curve,
BrepFace face,
double tolerance,
bool loose
)
Parameters:
  • curve
  • Type: Curve
  • Curve to pull.
  • tolerance
  • Type: double
  • Tolerance to use for pulling.
  • loose
  • Type: bool
  • If true, the curve's edit points are pulled back to the Brep face's underlying surface. If any edit point misses the surface, the curve will not be created.
Returns:
Type: Curve[]
An array of pulled curves, or an empty array on failure.
Available since:
8.17

Description:

Pull a curve to a BrepFace using closest point projection.

Syntax:
public static Curve[] PullToBrepFace(
Curve curve,
BrepFace face,
double tolerance
)
Parameters:
  • curve
  • Type: Curve
  • Curve to pull.
  • tolerance
  • Type: double
  • Tolerance to use for pulling.
Returns:
Type: Curve[]
An array of pulled curves, or an empty array on failure.
Available since:
5.0

/
/
/
PullToBrepFace

PullToBrepFace method

Class:  Rhino.Geometry.Curve

Nothing found