Description:
Fits a new curve through an existing curve.
Parameters:
- degree
- Type: int
- The degree of the returned Curve. Must be bigger than 1.
- fitTolerance
- Type: double
- The fitting tolerance. If fitTolerance is RhinoMath.UnsetValue or <=0.0, the document absolute tolerance is used.
- angleTolerance
- Type: double
- The kink smoothing tolerance in radians. If angleTolerance is 0.0, all kinks are smoothed If angleTolerance is >0.0, kinks smaller than angleTolerance are smoothed If angleTolerance is RhinoMath.UnsetValue or <0.0, the document angle tolerance is used for the kink smoothing
Returns:
Type: Curve
Returns a new fitted Curve if successful, None on failure.
Available since:
5.0