Description:

Calculates the boolean intersection of two closed, planar curves. Note, curves must be co-planar.

Syntax:
public static Curve[] CreateBooleanIntersection(
Curve curveA,
Curve curveB,
double tolerance
)
Parameters:
  • curveA
  • Type: Curve
  • The first closed, planar curve.
  • curveB
  • Type: Curve
  • The second closed, planar curve.
Returns:
Type: Curve[]
Result curves on success, empty array if no intersection could be calculated.
Available since:
6.0

Description:

Calculates the boolean intersection of two closed, planar curves. Note, curves must be co-planar.

Syntax:
public static Curve[] CreateBooleanIntersection(
Curve curveA,
Curve curveB
)
deprecated in 6.0
obsolete: Use version that takes tolerance as input
Parameters:
  • curveA
  • Type: Curve
  • The first closed, planar curve.
  • curveB
  • Type: Curve
  • The second closed, planar curve.
Returns:
Type: Curve[]
Result curves on success, empty array if no intersection could be calculated.
Available since:
5.0

/
/
/
CreateBooleanIntersection

CreateBooleanIntersection method

Class:  Rhino.Geometry.Curve

Nothing found