Description:

Evaluate the derivatives at the specified curve parameter.

Syntax:
public Vector3d[] DerivativeAt(
double t,
int derivativeCount,
CurveEvaluationSide side
)
Parameters:
  • t
  • Type: double
  • Curve parameter to evaluate.
  • derivativeCount
  • Type: int
  • Number of derivatives to evaluate, must be at least 0.
  • side
  • Type: CurveEvaluationSide
  • Side of parameter to evaluate. If the parameter is at a kink, it makes a big difference whether the evaluation is from below or above.
Returns:
An array of vectors that represents all the derivatives starting at zero.
Available since:
5.0

Description:

Evaluate the derivatives at the specified curve parameter.

Syntax:
public Vector3d[] DerivativeAt(
double t,
int derivativeCount
)
Parameters:
  • t
  • Type: double
  • Curve parameter to evaluate.
  • derivativeCount
  • Type: int
  • Number of derivatives to evaluate, must be at least 0.
Returns:
An array of vectors that represents all the derivatives starting at zero.
Available since:
5.0

DerivativeAt method

Class:  Rhino.Geometry.Curve

Nothing found