Description:

Determines the orientation (counterclockwise or clockwise) of a closed, planar curve in the world XY plane. Only works with simple (no self intersections) closed, planar curves.

Syntax:
public CurveOrientation ClosedCurveOrientation()
Returns:
The orientation of this curve with respect to world XY plane.
Available since:
6.0

Description:

Determines the orientation (counterclockwise or clockwise) of a closed, planar curve in a given plane. Only works with simple (no self intersections) closed, planar curves.

Syntax:
public CurveOrientation ClosedCurveOrientation(
Plane plane
)
Parameters:
  • plane
  • Type: Plane
  • The plane in which to solve the orientation.
Returns:
The orientation of this curve in the given plane.
Available since:
5.0

Description:

Determines the orientation (counterclockwise or clockwise) of a closed, planar curve. Only works with simple (no self intersections) closed, planar curves.

Syntax:
public CurveOrientation ClosedCurveOrientation(
Transform xform
)
Parameters:
  • xform
  • Type: Transform
  • Transformation to map the curve to the world XY plane.
Returns:
The orientation of this curve in the world XY-plane.
Available since:
5.0

Description:

Determines the orientation (counterclockwise or clockwise) of a closed, planar curve in a given plane. Only works with simple (no self intersections) closed, planar curves.

Syntax:
public CurveOrientation ClosedCurveOrientation(
Vector3d upDirection
)
Parameters:
  • upDirection
  • Type: Vector3d
  • A vector that is considered "up".
Returns:
The orientation of this curve with respect to a defined up direction.
Available since:
5.0

/
/
/
ClosedCurveOrientation

ClosedCurveOrientation method

Class:  Rhino.Geometry.Curve

Nothing found