Description:

Gets closest points between this and another curves.

Syntax:
public bool ClosestPoints(
Curve otherCurve,
out Point3d pointOnThisCurve,
out Point3d pointOnOtherCurve
)
Parameters:
  • otherCurve
  • Type: Curve
  • The other curve.
  • pointOnThisCurve
  • Type: Point3d
  • The point on this curve. This out parameter is assigned during this call.
  • pointOnOtherCurve
  • Type: Point3d
  • The point on other curve. This out parameter is assigned during this call.
Returns:
Type: bool
True on success; False on error.
Available since:
5.0

Description:

Finds the object (and the closest point in that object) that is closest to this curve. Breps, surfaces, curves and point clouds are examples of objects that can be passed to this function.

Syntax:
public bool ClosestPoints(
IEnumerable<GeometryBase> geometry,
out Point3d pointOnCurve,
out Point3d pointOnObject,
out int whichGeometry,
double maximumDistance
)
Parameters:
  • geometry
  • Type: IEnumerable<GeometryBase>
  • A list, an array or any enumerable set of geometry to search.
  • pointOnCurve
  • Type: Point3d
  • The point on curve. This out parameter is assigned during this call.
  • pointOnObject
  • Type: Point3d
  • The point on geometry. This out parameter is assigned during this call.
  • whichGeometry
  • Type: int
  • The index of the geometry. This out parameter is assigned during this call.
  • maximumDistance
  • Type: double
  • Maximum allowable distance. Past this distance, the research is given up and False is returned.
Returns:
Type: bool
True on success; False if no object was found or selected.
Available since:
5.0

Description:

Finds the object (and the closest point in that object) that is closest to this curve. Breps, surfaces, curves and point clouds are examples of objects that can be passed to this function.

Syntax:
public bool ClosestPoints(
IEnumerable<GeometryBase> geometry,
out Point3d pointOnCurve,
out Point3d pointOnObject,
out int whichGeometry
)
Parameters:
  • geometry
  • Type: IEnumerable<GeometryBase>
  • A list, an array or any enumerable set of geometry to search.
  • pointOnCurve
  • Type: Point3d
  • The point on curve. This out parameter is assigned during this call.
  • pointOnObject
  • Type: Point3d
  • The point on geometry. This out parameter is assigned during this call.
  • whichGeometry
  • Type: int
  • The index of the geometry. This out parameter is assigned during this call.
Returns:
Type: bool
True on success; False if no object was found or selected.
Available since:
5.0

/
/
/
ClosestPoints

ClosestPoints method

Class:  Rhino.Geometry.Curve

Nothing found