menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Extends a curve on a surface.
Syntax:
public
Curve
ExtendOnSurface(
CurveEnd
side
,
BrepFace
face
)
Parameters:
side
Type:
CurveEnd
The end of the curve to extend.
face
Type:
BrepFace
BrepFace that contains the curve.
Returns:
Type:
Curve
New extended curve result on success, None on failure.
Available since:
5.0
Description:
Extends a curve on a surface.
Syntax:
public
Curve
ExtendOnSurface(
CurveEnd
side
,
Surface
surface
)
Parameters:
side
Type:
CurveEnd
The end of the curve to extend.
surface
Type:
Surface
Surface that contains the curve.
Returns:
Type:
Curve
New extended curve result on success, None on failure.
Available since:
5.0
home
/
Rhino.Geometry
/
Curve
/
ExtendOnSurface
ExtendOnSurface method
Class:
Rhino.Geometry.Curve
Nothing found