Description:
Creates a revision cloud curve from a planar curve.
Parameters:
- curve
- Type: Curve
- The input planar curve.
- segmentCount
- Type: int
- The number of segments in the output revision cloud curve. If zero, the number of segments in the output revision cloud curve is based on the NURB form of the input curve.
- angle
- Type: double
- The angle in radians, between PI/2.0 and PI radians (90 and 180 degrees). This angle indicates the amount of bulge in the segments.
- flip
- Type: bool
- The arc segments in output revision cloud curve will be in the opposite direction to the input curve.
Returns:
Type: Curve
A revision cloud curve is successful, False otherwise.
Available since:
8.4
Description:
Creates a revision cloud curve from points that make up a planar polyline.
Parameters:
- points
- Type: IEnumerable<Point3d>
- The input points.
- angle
- Type: double
- The angle in radians, between PI/2.0 and PI radians (90 and 180 degrees). This angle indicates the amount of bulge in the segments.
- flip
- Type: bool
- The arc segments in output revision cloud curve will be in the opposite direction to the input curve.
Returns:
Type: Curve
A revision cloud curve is successful, False otherwise.
Available since:
8.4