Description:

Constructs a 3D NURBS curve from a list of control points.

Syntax:
public static NurbsCurve Create(
bool periodic,
int degree,
IEnumerable<Point3d> points
)
Parameters:
  • periodic
  • Type: bool
  • If true, create a periodic uniform curve. If false, create a clamped uniform curve.
  • degree
  • Type: int
  • (>=1) degree=order-1.
  • points
  • Type: System.Collections.Generic.IEnumerable<Point3d>
  • control vertex locations.
Returns:
new NURBS curve on success None on error.
Available since:
5.0

Nothing found